Chirping or Beeping PLT 400 on Startup with no Connection - Root Cause + Fix

  • Updated

This article is to help those that are experiencing an issue where the PLT 400, on startup, is chirping, beeping, or blinking rapidly, without connecting to the tablet.

Root Cause

The most likely reason for this is because the firmware for your tool has not been updated to recognize B22-4.0 batteries that have been produced by Hilti since May 2026. To see if this might be your case, simply look at the back of the battery you are using and see what the production date is (as in the image below):

How to Fix

To overcome this issue, please simply ensure you have the most recent firmware installed (certainly at least FW 3.2.409 or higher). Please see this article on how to update your firmware via the HCL tablet. For this case, during the update, you will need to use a battery that is produce prior to May 2026. Once it has been updated, however, you can use all B22-4.0 batteries as normal.

If you do not see FW 3.2.409 or higher available on the Firmware update server, please reach out to your local specialist, where they can update it manually.

What the Error Looks Like - Details for Transparency

  1. Tool is turned on, LED light begins flashing normally
  2. After ~35 seconds, the tool starts beeping loudly, 1x per second, with the LED flashing rapidly
  3. After ~70 seconds, the tool begins the field calibration process, but continues to flash and beep loudly
  4. Once the calibration is complete, the tool continues to flash and beep loudly
  5. Once an attempt is made to connect to the serial number of the tool, the PLT 400 begins chirping in high-pitch rapid bursts, and the LED blinking becomes erratic

The way to fix this is to simply update the firmware. Please contact a specialist if the solution above is not working for you.

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